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Introduction 

This training contains an assortment of examples on the use of parameters in SCIA Engineer. 

What is the purpose of using parameters in SCIA engineer? Imagine that a SCIA Engineer user deals nearly 
every day with the same type of structure. Only the dimensions, cross-sections, height, number of spans, 
etc. differ in the projects. For such differences, parameters can be used as where in SCIA engineer the 
functionality 'Parameters' servers for. 

Every 'version' of the same type, as mentioned in the above, can be parameterized. The parameters are fully 
editable and when changed they may lead to a very straightforward modification of the analysis model. 

What’s more, a model defined by means of parameters can be saved as a template. When opened, the user 
is first asked to fill in the table with all the parameters present in the model. This may be effectively used for 
creation of simple "programs" for e.g. calculation of continuous beam, simple frame, etc. 

The user has to create the structure only once and save the structure as a template of a specific type. Then 
he/she only has to define the parameters for every new project, instead of creating a whole new structure 
from scratch each and every time. The modelling is thus only done once in the initiation of the template file 
and the user can immediately proceed to calculation and evaluation of results after the parameters are 
defined. 

This leads to a huge reduction of the working hours on one side and a less human error sensitive approach.  

Besides the above, this workshop contains also some extra’s which can help the user to become more 
effective in working with SCIA Engineer:  

- XML: one of the formats SCIA Engineer supports to export and import a project from.  
- ODA: One Dialog Application 
- Batch optimizer: the user can give a range of values for a parameter and the solution is also a 

range of results. This could be used to chose the most effective value to obtain a certain result. 
- User blocks: a project can be saved as a user block together with its parameters. Afterwards, this 

block can be imported  in another project.  
- Project templates: as mentioned before, the user can make a standard project which can be used 

for all the other projects of the same type. 
 

Most of the options in the course can be calculated/checked in SCIA Engineer with a license for a 
professional edition or the separate Parametric modelling module. 

For some supplementary checks an extra module (or edition) is required, but this will always be indicated in 
those paragraphs. 
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Below you can find an image of the workspace of SCIA Engineer and where to find the different menus. 
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EXAMPLE 1: Beam on two supports 

 

Example: "Beam parametric.esa" 

 

We will parametrize the length and cross section dimensions of a simple concrete beam supported on two 
ends. 

Project data: 

• Structure type: frame XZ 

• Materials: concrete C30/37 

• Functionality: 'Parametric Input' 
 

Create a beam with the below properties: 

 

 

When starting a parametric project we are using default values for the properties we are going to 
parametrize later on. These can be chosen randomly. 
6m for the length of the beam in this case and 500x300mm for the dimensions of the cross section. 
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Definition of parameters 

Before being able to apply parameters in our project we have to define a list of parameters. You can do that 
in the library by going to "Libraries" > "Tools" > "Parameters" in the main menu. 

Each parameter has a "Name", "Type" and "Description" property by default. 
For "Name" better use a short string because a parameter can be used in the formula for the definition of 
another parameter. 

Insert the below properties in the model: 

 

Note that when defining a parameter if a certain type already a value has to be assigned. For the width we 
chose to apply a formula instead of a value so that the width of the beam in this case is always half the 
length of the height. 

 

Assigning parameters 

If you used the correct type for all the parameters you can simply assign a parameter to any values in the 
project of that type by clicking on the dropdown menu. 

Change the X-coordinate of the end beam to parameter "L": 
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Change the height of the cross section to parameter "H": 

 

 

 
Change the width of the cross section to parameter "W": 

 

Note that in the actual values of the properties are now replaced width the name and description of the 
chosen parameters. While in the model the values of the parameters are taken into account (length of 6m, 
height of 600mm and width if 300mm). 
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Parameter template sets 

Now we can define different sets of values for the parameters we created. Go to "Libraries" > "Tools" > 
"Parameters template set": 

 

 
You can for example have one set for the geometry, one set for the loads, one set for stiffnesses of the 
supports etc. In this case we added all parameters to the "Geometry" set with "Add all" button. 

Valuate parameters 

Each set of parameters can now be changed via the template manager: "File" > "Template manager" in the 
main menu: 

 

 
Use the "Refresh" button to update the preview window to see the effect of the changements. 
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In the template manager you can also save and load different sets of parameter values for each template: 
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EXAMPLE 2: Cross-sections 

 

Example: "Cross-sections parametric.esa" 

You can start this exercise from where you ended the previous one ("Beam parametric.esa"). 

 

General cross-section 

We are going to create two additional parameters which we are going to use for creating a general cross 
section. In the main menu go to "Libraries" > "Tool"  > "Parameters" and create the below parameters: 
 

 

Note that each name has to be unique so better also add a clear description for each parameter. 

 

As opposed to a standard library cross section, for general cross sections parameters can't be assigned 
directly to properties. In the project create a new general cross section and that there is a parameter setting 
in the general editor itself: 
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Click on it and define a parameter for the width and the height as we are going the make a (general) 
rectangular cross section: 

 

Make sure to enable the "Export properties of cross section".  
We chose for the exact same naming as we did in the first step when defining the parameters of the project. 
Because that way we can easily assign the "general cross section parameters" to the parameters defined in 
the project, see below. 

Now create a random rectangle with the "Polygon" option, but start in the origin of the editor window: 
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Then select the top two nodes and assign H1 to "Z": 

 

 
And select the right hand side two nodes and assign W1 to "Y": 

 

Close the window with "Close" and in the next window we can assign the parameters of the project to the 
parameters of the general cross section: 
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We can now also create a separate set of parameters for the general cross section. Go to "Libraries" > 
"Tools" > "Parameters template set" and add a new set: 

 

For each set there is a different tab in the template manager: 
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Cross sections as parameter 

In SCIA Engineer it’s also possible to parameterize libraries. Such as: materials, cross-sections, 
reinforcement, subsoils,… 

In this topic, we will explain it for the cross-sections library. The other library types can be handled in the 
same manner. 

Create one additional circular cross section in the project with a diameter of 400mm, this is how the cross 
section library should look now: 

 

We are going to use cross sections as parameters, for this we need one master cross section which is fictive 
and will serve as the "selector". Copy the first cross section in the list and enable the "selector" switch: 
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With this option enabled we can now go to the parameters window ("Libraries" > "Tools" > "Parameters") and 
add a cross section parameter with the below properties: 

 
 

Under "Select Alternatives" you can select the alternatives for this parameter using the SHIFT button to 
select multiple cross sections. 
The cross section chose under "Alternative" will then be the applied cross section. 

Lastly apply the CSS parameter to a 1D element in the project, you chose the cross section which we named 
MASER in one of the previous steps: 
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We can add this parameter also to a parameters template set: 

 

And switch between cross sections in the template manager ("File" > "Template manager") from the main 
menu: 
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EXAMPLE 3: catalogue block 

 

Example: " Catalogue block parametric.esa" 

We will parametrize the length and cross section dimensions of a simple concrete beam supported on two 
ends. 

Project data: 

• Structure type: frame XYZ 

• Materials: concrete C30/37 

• Functionality: 'Parametric Input' 
 

Parameters 

• Create the following list of parameters by going to "Library" > "Tools" > "Parameters": 
 

 

Close the window and click on "yes" in the next pop-up window to validate values that are calculated based 
on the formula's we chose. 



Annex B 

MV – 2023/11/17  19 

 

• Filter the input panel "categories" filter on "Import & Blocks" and chose for "Catalogue  blocks". 
Under "Frame 2D" in "Available groups" chose the first Catalogue block , add a rectangular cross 
section and click on "OK". Assign the above parameters as shown below: 

•  
• Input the frame on coordinates "0 0 0" and add hinged supports on the bottom of the columns: 

 

 
 

Anytime the parameters are changed in the project, the dimensions of the block will change along 
and you can insert a new block in the project with those new parameters: 
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• We want a grid now that changes along with the parameters so we can quickly see what block was 
inserted. Filter the input "Categories" filter on "Grids & Storeys", chose for "3D line grid" and assign 
the below parameters to define a parametric grid: 
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EXAMPLE 4: plate on subsoil 

 

Example: "Subsoil plate parametric.esa" 

We will parametrize the length and cross section dimensions of a simple concrete beam supported on two 
ends. 

Project data: 

• Structure type: general XYZ 

• Materials: concrete C30/37 

• Functionality: 'Parametric Input' 
 
Create a plate on a subsoil with the below initial parameters: 
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• Go to "Libraries" > "Tools" > "Parameters" and add the below parameters: 
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Go to "Libraries" > "Tools" > "Parameters template set" and add one set for geometrical parameters and one 
set for load parameters: 

 

• Now assign the parameters to the proper properties in the model as shown below: 
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• Also add a surface load on the slab in different load cases and subregion and make the value 
parametric as shown below: 

 

 

• Save the project and afterwards the project is parametrized via "File" > "Template manager" from the 
main menu. 
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EXAMPLE 5: Cellular beam 

 

Example: "Cellular beam parametric.esa" 

Project data: 

• Structure type: general XYZ 

• Materials: steel S235 

• Functionality: 'Parametric Input' 
 

Create a beam with the below initial properties: 
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• Go to "Libraries" > "Tools" > "Parameters" and add the below parameters: 
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• Apply the below parameters to the cross section: 

 

• And parametrize the length of the beam: 

 

• Set  the input panel "Categories" filter to "1D member" and chose for "Opening on 1D". Apply the 
below parameters in the dialogue, click on "OK" and select the beam. 
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• Go to "Libraries" > "Tools" > "Parameters template set" and make a set of parameters for the cross 
section, the geometry and the web openings: 

 

Enable 3D preview. Afterwards you can go to "File" > "Template manager" to change parameters and have a 
preview of the adjustments: 
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EXAMPLE 6: Reinforcement on beam 

 

Example: "Reinforcement beam parametric.esa" 

Project data: 

• Structure type: Frame XZ 

• Materials: Concrete C30/37 

• Functionality: 'Parametric Input' 
 

Create a multispan beam with the below initial properties: 

 

Type "reinforcement on whole beam" in the Scia Spotlight and add some reinforcement bars on the beam 
with the below scheme: 
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• Go to "Libraries" > "Tools" > "Parameters" and add the following parameters to the model: 

 



References and literature 

MV – 2023/11/17  33 

• Select the properties of the elements in the model and assign the corresponding parameters: 
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• Go to "Libraries" > "Tools" > "Parameters template set" and create a set for the geometry, cross 
section, reinforcement and the loads. They are now changeable in the project template settings 
under "File" > "Template manager": 

 

 

• Save the project as a template. You simply do this by saving the project in the template folder. By 
default this should be: 
C:\Users\*YOURUSERNAME* \Documents\ESA*XX.X*\Templates 
Or check the location here in the global UI settings: 

 

 

 

• Now you can easily open this file from the project browser: 

 

And everytime you do so you will be asked what you want to set as values for the parameters: 
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EXAMPLE 7: Water and ground pressure from soil 

 

Example: "Soil parametric.esa" 

Project data: 

• Structure type: General XYZ 

• Materials: Concrete C30/37 

• Functionality: 'Parametric Input' 
 

Create a rectangular concrete basement with 2D elements and below dimensions. 
Add a borehole profile on coordinates "0 0 0": 

 

We are going to let the water pressure and soil pressure depend on the height of both the geological profile 
aswell as the water level. Create a load case for each and apply soil and water pressure. Make sure all loads 
are pointing inwards and possibly switch orientation if this is not the case: 
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• Go to "Libraries" > "Subsoil and foundation" > "Subsoils" in the main menu and add a number of 
subsoils to the database with different values for C1z. Add one "Dummy" subsoil on top of the list 
and enable the "Selector" option, this soil will serve as our toggle switch: 

 

• Go to "Libraries" > "Subsoil and foundation" > "Geologic profiles" from the main menu and add a 
number of profiles. In this example we are going use these profiles to switch between water levels so 
therefor use the same ground properties but change height of water level for each profile. Add one 
"Dummy" profile on top of the list and enable the "Selector" option, this profile will serve as our 
toggle switch: 

 

• Go to "Libraries" > "Tools" > "Parameters" and define the below parameters: 

 

For the soil and geological profiles chose all the options from the list you defined under "select alternative". 
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• Now apply the correct parameters to the variables in the model as shown below: 

 

 

• Go to "Libraries" > "Tools" > "Parameters template set" and define one set of parameters. 

• Go to "File" > "Template manager" and set the below values for the parameters: 
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• Run the calculation, go to "Results" > "Surface loads" from the main menu and verify the ground load 
starts at one meter from the top and the water load starts at two meters from the top: 
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EXAMPLE 8: Layers 

 

Example: "layers parametric.esa" 

Project data: 

• Structure type: frame XZ 

• Materials: steel S235 

• Functionality: 'Parametric Input' 
 

Create 4 beams supported on hinges: 

 

We are going to change the amount of spans by using both the layer visibility and "structural layer only" 
property. 

Therefor make 4 different layers, one for each span and assign each beam to a different span layer: 
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• Go to "Libraries" > "Tools" > "Parameters" and create the below parameters: 

 

With the Boolean for the layers we are changing the visibility, with the Boolean for the structural type we are 
going to take a certain beam into account in the analysis or not. 
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• Go to "View" > "Visibility" > "By Layers" from the main menu and apply the layer parameter to the 
activity toggle switch: 

 

• Go to "Libraries" > "Layers" from the main menu and link the "structural only layer" toggle switch to 
the corresponding Boolean parameter: 
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• The amount of beams in both visibility and analysis now depends on the "span" setting: 
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EXAMPLE 9: Steel hall 

 

Example: "Steel hall parametric.esa" 

Project data: 

• Structure type: general XYZ 

• Materials: steel S235 

• Functionality: 'Parametric Input' 
 

We are going to create a steel hall with a varying amount of frames using the same principle as we used in 
the previous example. 

Create a frame with the below parameters (search for “catalogue blocks” in the command line and chose for 
frame 2D): 

 

Afterwards copy the frame a number of times with the multicopy tool, note that the amount of copies you 
chose here will be the maximum amount of frames the hall will ever contain. 

Also select the top nodes within the multicopy and enable “connect selected nodes with new beams”: 
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The total structure should look something like this: 
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• Go to "Libraries" > "Tools" > "Parameters" and create the below parameters: 

 

 

 

 

 

 



References and literature 

MV – 2023/11/17  47 

 

 

You can already assign “H1” and “Htot” tot the Z-coordinates of the roof and “L” and “Middle” to the X-
coordinates of the frame: 
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• Go to "Libraries" > "Tools" > "Parameters" again and for each copy of a frame you create the below 
parameters: 

o One that calculates the Y-distance of the frame: 

 
o One that decides wether the layer should be active or not (in this case as opposed to the 

previous example we test if the length of the hall is smaller than the total length): 

 
o One that decides wether the layer should be of type “structural layer only” or not (this should 

give the opposite Boolean and the previous one): 
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• Now for each frame assign the correct parameter to the Y-coordinate of the corresponding frame: 

 

• Go to “View” > “Visibility” > “By layers” and set the proper activity parameter to the proper layer: 

 

• Finally go to “Libraries” > “Layers” and set the proper parameter for the “structural model only” 
option: 
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XML 

 

SCIA Engineer allows for the exchange of data with third-party applications through the popular and powerful 
XML format. Moreover, XML format can be used to develop tailor-made applications that use SCIA Engineer 
as a "hidden" engine working on the background and performing calculations of company-specific problems. 

The XML file editor is very similar to the Document of SCIA Engineer. The principle is that the user defines 
tables describing individual entities of the SCIA Engineer projects and there order. This table-form can be 
easily previewed (it is in fact identical to the standard SCIA Engineer document). When ready, the final XML 
file contents can be transformed into the real XML format through the export function. 

 

Open example 9 again: “Steel hall parametric.esa”. 

Go to “File” > “Export to” > “XML” from the main menu and close the next window where you are asked to 
open a XML definition template (we are starting from scratch so this is not required now). You’ll then land in 
a window where you can set up an XML definition of the project you created. We are just going to add the 
parameters of the project to the XML format: 

 

 

Once added click on the export button and save the file to a local destination: 

 

mk:@MSITStore:C:/Program%20Files/SCIA/Engineer2008/ESA.chm::/html/Introduction_to_document.htm
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Open the text file with any text editor. 
Here you can find the XML definition of all parameters. Change “h7” of any parameter, which is the actual 
value, and save the file: 

 

If you now update the Scia project with this information you will see the parameter has been changed. 
You do that with “File” > “Update from” > “XML” from the main menu. 

The above approach you can use to design your own custom tools which change the XML format of the 
representation of any of your analytical projects. Possibly provided with parameters. 
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User blocks & project templates 

 

User Blocks 

SCIA Engineer enables the user to make a library of his/her projects that are used over and over again. 
These projects may be at any time included into a newly created project or appended to an earlier created 
and currently edited project. 

The projects in this user-created library are called User blocks and the library is called User block library. 

 

We will again use example 9: ““Steel hall parametric.esa”. 
 

• Open the file and save it as a user block by going to “File” > “Save as” and saving it in the folder your 
chose for saving user blocks. Which one that is you can find in the global setup: 

 
 

• Create a new general XYZ project and go to “User blocks” in the input panel: 
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There you should now find the parametric project you just saved in this folder: 

 

Next a window appears where you can change the parameter values in before importing the project: 
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Project templates 

In practice it may quite often happen that some elements are used in every project. For example, material 
types, cross-sections, predefined loads, and even parts of a structure may be the same in various projects. 
Therefore, it would be efficient, if the user could store the repetitious elements aside and load them quickly 
into every new project. 

In SCIA Engineer this may be achieved via templates. Generally speaking, a template is an ordinary project 
that holds required information and is saved in a special way. 

We will again use example 9: ““Steel hall parametric.esa”. 
 

• Open the file and save it as a template file by going to “File” > “Save as” and saving it in the folder 
your chose for saving template files. Which one that is you can find in the global setup: 

 

 

• Now close the file and go to “Project manager” from “File” in the main menu: 

 

There you should now find the template project you just saved. 
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• Again, if you open a template which was set up in a parametric way a window appears before the 
project is opened that allows you to change the parameters. As opposed to user using blocks, the 
parameters are now kept within the project: 
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Parameterizing - GENERAL 

 

Types of parameters 

 

 

When in doubt wether a certain property can be parameterized or not, you can try to create as many types of 
parameters as possible. If the property is something you can parametrizise the parameter will show as a 
dropdown list. 

Possible formulae 

 

 



References and literature 

MV – 2023/11/17  57 

Possible operators 

 

Example: 

 

 

 

 


